Having trouble signing up for Insightly?

When you sign up for Insightly, we'll verify your email address and get your account set up in just a couple of minutes. But sometimes unexpected things happen and we'll need to help you sort them out. (Oh, computers!!) Here are some tips:

Not getting our verification email? If you're not verifying your email address through Google, we'll send you an email message with a verification link. If you don't receive that email, there are a few places you can check for it, like your spam folder. Take a look at Resolving missing invitations, password resets, or notifications for more ideas.

Try a different browser. Different web browser add-ins and versions may make your setup unique and cause problems with some web pages. See if you can complete the sign-up in a different web browser.

Getting errors? If you get errors during the sign-up process, please let us know! To do that… well, you'll need to sign up here in the Help Center and add a comment below. Click the Sign In button above and create your Help Center account. (Use the same email address you'd like to use for Insightly—this will help us find your account information, if one was created.)

2

Comments

6 comments
  • Hello. 

    My last two days using insigtly were terrible.

    It gets too much time to login... When it does, the inicial page does not load completely.... When I click at tasks, for example, besides it takes to much time do load, the page does not load completely and sometimes press F5 works, sometimes NOT.....

    I use chrome, but today I made a test at the Edge and just the LOG IN was faster, but the rest of it have the same problems.

    The rest of my team HAVE NO PROBLEM, just me! 

    Any suggestion?

     

    Thanks

    0
    Comment actions Permalink
  • Hi Bruno:

    Are you working on Windows 10 by any chance? If you are, our development team is aware of an issue with Insightly and a recent Windows 10 update, Version 1703. To check your Windows version, go to Control Panel > System, and for the build, you can do this by hitting Start, type “winver,” and then press Enter.

    If find that you are on this version of Windows, there is a fix from Microsoft you can download from their website here.

     

    0
    Comment actions Permalink
  • Hi Lyla, thank you for the feedback!

    I have the 1703 version of W10..... The link you send was corrupted.. can you give more details of what should I download on windows page?

    Regards,

    0
    Comment actions Permalink
  • Sorry about that Bruno!

    I've updated the link from my prior post but you can also find more information about this on the Microsoft Community in this thread.

    0
    Comment actions Permalink
  • Lyla, 

    I LOV U.....

    Thanks, it worked so well and fast!! I get my CRM Back!!!

    Tnks

    0
    Comment actions Permalink
  • Aww gee thanks Bruno, glad to hear it worked :)

    0
    Comment actions Permalink

Post is closed for comments.