Answered

Bulk Unfollow

I'm not sure how this happened but I am somehow following 100s of Contact records and I don't want to. Maybe it was an error when I uploaded the contacts? Either way, I don't want to follow them because I'm receiving email notifications when someone changes the record. I know how to unfollow one at a time but it's taking forever.

How do I bulk unfollow?

5

Comments

20 comments
  • Hi Rebecca,

    You can review your settings by going to User Settings > Follow.

    0
    Comment actions Permalink
  • Thanks, Nora. That helps for future records - but how do I unfollow everyone I'm currently following?

    0
    Comment actions Permalink
  • Hi Rebecca, 

    Unfortunately we don't have an option right now to unfollow all of your records simultaneously or unfollow records en masse.  This would be a great suggestion for our Ideas & Suggestions page, and I'm sure other Insightly users are interested in seeing this feature added as well.

    0
    Comment actions Permalink
  • That's too bad. Because I'm the one who uploads records and I think I somehow defaulted to following them all - really frustrating as I didn't want to follow them. And now I'm getting a ton of emails notifications.

    0
    Comment actions Permalink
  • We're sorry for the inconvenience, Rebecca.  Thank you for being so understanding.

    Moving forward, however, you should be all set.  Once you've customized your auto-follow settings, you'll only follow what you want to follow.

    0
    Comment actions Permalink
  • Same thing happening me,. Contacts are being "followed" automatically. I have not requested to follow any and its really really annoying, 

    0
    Comment actions Permalink
  • Hi Séamus,

    Did you review your settings by going to User Settings > Following to make sure that you don't have a setting checked off there that you don't want?  It looks like "Records I Update" is the primary culprit when people are following too many records, so I would check to make sure that option is unchecked.

    0
    Comment actions Permalink
  • What's frustrating is it wasn't until recently that I started receiving the emails. Did you guys change a setting on the backend that defaulted to this setting? Or is it just that none of these records were touched in the past 6 months? I don't own most of these records nor was I the one who updated them. Someone else did but because I uploaded them into insightly I somehow get notifications. Can you remove that default setting? Or add a bulk un-do to development?

    0
    Comment actions Permalink
  • Hi Rebecca,

    We recently updated our Notification and Auto-follow settings to give our users more control over when and how they are notified about their account.  In your case, the auto-follow option to follow "Records I Create" had already been selected, but the option to be notified when "Record is updated" hadn't been added yet, so you weren't getting the notification emails.

    Again, we're sorry for the inconvenience and for any confusion this has caused.  Let us know if there's anything we can do for you. :)

    0
    Comment actions Permalink
  • OK, so just to confirm, the reason for the sudden influx of emails is because you turned something new on and auto-followed it for me. I have another colleague that has the same issues and she and I are both pretty frustrated. Is there anyway you can roll that back on your end as it's not a change we asked for? Having to manually unfollow thousands of records and/or getting 5-10 emails a day about this is really annoying.

    0
    Comment actions Permalink
  • Hi Rebecca:

    This isn't something that can be rolled back but as Dan mentioned once you've customized your auto-follow settings, you'll be following less records and will receive fewer notifications moving forward.

    1
    Comment actions Permalink
  • Thanks, Lyla. Unfortunately, I'm still following 100s of names and it's incredibly annoying. While I'm happy there won't be additions in the future because I changed my settings I do wish there was something you could do on your end as it was never something I wanted but now I'm stuck with it. Or spend the time (not insignificant) to un-check every one of the record.s

    0
    Comment actions Permalink
  • Hey Rebecca,

    I've made sure to let our Product and Engineering teams know about the experience that you've had during this most recent update so that they can make use of your feedback for future Insightly updates.

    I know this doesn't make having to manually un-check each follow any better for you, but I hope it lets you know that we do listen to your feedback, and we'll work to make sure you don't have an experience like this again in the future.

    1
    Comment actions Permalink
  • I'm having this exact same issue and it's disappointing that Insightly aren't able to help. Manually unfollowing every single record is just a waste of people's time, as is reading and deleting a tonne of irrelevant emails. I have tried turning off notifications completely but then I ended up missing notifications that I actually did want to see and were important.

    Insightly, are you sure that there's really no way to fix this from your side? As it would save everyone a whole heap of time and effort

    0
    Comment actions Permalink
  • There isn't an option to unfollow records in bulk, Ian. You may want to check out the Ideas & Suggestions section to see if this has already submitted by another user and add your vote. If you don't find it, you can start a new thread.


    0
    Comment actions Permalink
  • I added it to Ideas and Suggestions. Whoever is following this post, please vote for it so we can get insightly to fix it!

     

    https://support.insight.ly/hc/en-us/community/posts/115007833988-Bulk-Unfollow 

    0
    Comment actions Permalink
  • This is a joke, I did a bulk update and now I'm following nearly 13000 records with no way to change it! 

    1
    Comment actions Permalink
  • @Sam seriously!  What a joke!  Feel like such an idiot for going with this verses salesforce.  The cost savings means nothing compared to all the time I've lost trying to work this CRM.

     

    Lol why would it default have me follow other records?  I'm the lead on importing lists so I feel like they would have already addressed this issue.

    1
    Comment actions Permalink
  • I found a quick way to unfollow leads.  Go to user settings and click on follow.  There's a link on the bottom right that says "View Items I'm Following".  When you click on that, go to the tab "leads".  From there you can just click on all of the leads you are following and it will unfollow them.  It automatically puts the next one at your cursor so you don't even have to move it.  Just click!

    2
    Comment actions Permalink
  • hmmm....

    0
    Comment actions Permalink

Please sign in to leave a comment.