Completed

Link address with contact and company

Hi!

Every time I create a new contact and added to the company, I have to enter the physical address on the company profile and the contact profile.That is very annoying and creates double effort.

I have used SUGAR for at least 6 years and there is a function where you just click on it and gives you the option to attach or synchronise the info including phone number to the person and all the way around.

1

Comments

13 comments
  • Hi Caroline,

    You can use Bulk Editing to copy the address and phone number information to a contact record from its primary linked organization, or vice versa! :)

    Simply select the records you'd like to update and click the Bulk Edit button.

    Then, select the items you'd like to apply to your records and save.

    It's important to note that, if your contacts have any portion of their address or phone number filled in already, this process won't work correctly.  To get around that, make sure the record's fields are empty or empty them yourself by using the Change Field Value option in the bulk edit to insert a space (" ") in the field you want blank, then make the transfer.

    I hope that helps! :)

    0
    Comment actions Permalink
  • It does not because I have to go under all the list of contacts ... not friendly user either. The idea (and I use as an example sugar CRM) is to be able to do that once you are on the individual contact...I can send you screen shots.

    0
    Comment actions Permalink
  • I tried this method, but it only copied over the phone number from the organization to the contact; it did not successfully copy the address from the organization to the contact. As a result, the contact's address only says "United States". Why didn't this work?

    0
    Comment actions Permalink
  • Hello Debra,

    Can you provide screenshots of your example where the address did not copy from the Organization to the Contact? 

    Thanks for your help and patience!

    0
    Comment actions Permalink
  • Hi, I also tried using the Buld Edit feature but it didn't do anything. 
    Do you still need a screenshot? What you'll see is basically a contact without address details. 

    0
    Comment actions Permalink
  • To be more precise, I am not able to perform this step 

    "It's important to note that, if your contacts have any portion of their address or phone number filled in already, this process won't work correctly.  To get around that, make sure the record's fields are empty or empty them yourself by using the Change Field Value option in the bulk edit to insert a space (" ") in the field you want blank, then make the transfer."

    There is no option to leave a blank space for the field "Country". 

    0
    Comment actions Permalink
  • Hello Georgi,

    Can you provide the URL for which you gathered the above statement? And, a screenshot isn't needed any more thanks. I do need your exact steps, however, to help replicate this issue on my end. 

    Thanks for your help and patience!

    0
    Comment actions Permalink
  • The above statement is just the fist answer is the first answer in this thread (made by a colleague of yours). 

    I do the following:

     

    First I tried selecting the contacts I wanted to edit, then click on the bulk select option (pencil ion) and then select these options:

     

    Copy Phone Numbers from default linked Organization to Contact
    Copy Addresses from default linked Organization to Contact

     

    unfortunately nothing happened and the addresses weren't edited. 

     

    Then I followed the instructions in the first post and did the following:

     

    - select the group of contacts I want to edit and then click on the pencil icon (bulk edit)

    - Change field value - Mailing Address-> Country

    - I get a drop down field and must choose an option, thus making it impossible to male the filed empty. 

     

    I hope this helps. 

     

    0
    Comment actions Permalink
  • Hello Georgi,

    Thanks for that information!

    Keep an eye out for an email from me. I'll be creating a ticket to help further troubleshoot this issue. 

    I appreciate your patience. 

    0
    Comment actions Permalink
  • Hi guys, it seems, that the issue has appeared again. I don't know why, but I am again unable to bulk edit contacts, as I cannot use bulk edit to remove the value in the Mailing Country field. 

    0
    Comment actions Permalink
  • Hello Georgi,

    When you attempt to bulk edit your contacts to remove the value in the Mailing Country field are you also replacing it with a different value?

    Thanks for your time and patience. 

    0
    Comment actions Permalink
  • Hi Alejandro, 

    exactly this is the problem. I want to leave this field empty, but I do not have this option. The only option is to replace one value with another (one country with another country). It this field is not empty, I am not able to bulk edit the addresses of my contacts (Copy Addresses from default linked Organization to Contact). 

    0
    Comment actions Permalink
  • Hello Georgi,

    Thanks for the clarification this helps!

    As a workaround, I suggest creating a linked item report for Contacts which will allow you to add the Organizations linked address & country to your report. Then you'll want to add the "Contact ID" field to your report. All these fields you'll add from the "Report Fields" section. 

    In conclusion, this will provide you with a report the addresses from Organizations that you wish to copy over to specific Contacts. Which you can then update the records via import. This is why you also need the Record ID # since this is how Insightly makes updates existing records.

    Once you have your report all set you can follow these steps:

    1. First, Export the records you'd like to update
    2. Edit the file to change the records
    3. Import the file and choose the "update records" option

    Some other tips about this process:

    • Add New Records will still use duplicate checks when importing.
    • Update Existing Records will ONLY find a match by record ID and update the matching record
    • Add New Records and Update Existing Records will do both
    • There is no undo button, so we recommend testing a small subset first. But you could always update your import file and try to update again. :)

    I hope that helps! 

    0
    Comment actions Permalink

Please sign in to leave a comment.