Answered

ZOHO (email only) + Insightly email setup problems

Hello,
 
I'm trying to complete the "link email accounts" section of the first Getting Started task for initial Insightly onboarding. We are currently using ZOHO for email, but would like to use Insightly for its CRM features. It appears that Insightly can use a SMTP login for email linking and ZOHO provides the following SMTP information: https://www.zoho.com/mail/help/zoho-smtp.html
 
However when entering in the information suggested I get the following error from Insightly: The username and password you supplied was not correct.
 
I'm pretty sure that the username is the issue, but I'm not sure what value to use. I've tried
Any suggestions would be greatly appreciated.
 
Cheers,
 
~Jeremy
0

Comments

18 comments
  • Hi Jeremy,

    From the documentation provided by ZOHO, it looks like you'll want to use the email address that you use to login to your ZOHO account, and the password associated with that ZOHO login. 

    If you're still having trouble setting up your SMTP after testing that, could you send me a screenshot of the information you're entering (preferably with part of your email address blocked) so I can see more details?

    0
    Comment actions Permalink
  • The initial post has a screenshot with the information I'm entering (which is the email associated with my ZOHO account). The password is my ZOHO email password. The only other thing I can think of is I am using 2-step authentication with my ZOHO account.

    0
    Comment actions Permalink
  • Hi Jeremy,

    The image you placed in your original post is showing a broken link for me.  Can you link it from your desktop instead?

    0
    Comment actions Permalink
  • Ah, looks like it's (ironically) being hosted on a ZOHO server so is behind their auth. Here's an upload:



    0
    Comment actions Permalink
  • Hi Jeremy:

    I checked Zoho's support documentation on set up and the 587 Port is for TLS security. So the login credentials may not match the URL. Let's try a different port for SSL security, here's how:

    First enter mail.zoho.com as the SMTP Server and click Next:

    On the next page, it will tell you that we can not connect. Then you will change the URL to smtp.zoho.com and SMTP Port to 465, then click Next. You will then be asked to enter your login credentials:

    Hope this helps point you in the right direction. If this doesn't work, please let us know what error message you get.

     

     

     

    0
    Comment actions Permalink
  • Still no dice. I get the same error (when trying all the above mentioned User Names):



    0
    Comment actions Permalink
  • Hi Jeremy:

    Can you check to see if the User Name required to connect to Zoho is your email address? In several email services, they are the same.

    0
    Comment actions Permalink
  • I've tried: 

    • jeremy
    • jeremy@breachgate.com
    • a numerical User ID that I found in my ZOHO account dropdown (which was what in my last screenshot)
    0
    Comment actions Permalink
  • Hi Jeremy,

    Could you try going through the process as you originally did, but disabling the SSL checkbox?

    0
    Comment actions Permalink
  • Hey Dan,

    No success when disabling the SSL checkbox and trying the previous login permutations.

    0
    Comment actions Permalink
  • Hi Jeremy,

    I did a bit more digging, and I may have another solution.  Try using smtp.breachgate.com for the server name and your full email as the username.  Make sure SSL is disabled as well.

    0
    Comment actions Permalink
  • When entering that into the SMTP field I get the following message (before being prompted for any of the username/password text fields):

    0
    Comment actions Permalink
  • Hi Jeremy,

    I'm sorry to hear that didn't work.  I noticed your email domain actually originated from enom.com, not Zoho, so I thought there was an off chance that the domain was created outside of Zoho's systems and thus required a different procedure.  It looks like they may just be the 3rd party provider for Zoho.

    At this point, it might be best to reach out to Zoho support to see what we're missing here.  Looking over their help articles, they mention that having two-factor authentication enabled may cause issues, requiring you to go through extra steps, but it's also possible that your email is being routed through an alias, which is preventing your settings from authenticating.  Zoho will have access to your details, and should be able to verify what you need to use more effectively than we can now that we've gone through the basics.

    Let us know how that goes!

     

    0
    Comment actions Permalink
  • After having gotten the ZOHO guys up to speed on the problem they gave me the following response:


    "We have checked with our technical team and we do not have any expertise with Insightly service, so we request you to check with your Insightly team for any error messages while connecting via smtp server and update us accordingly."

    0
    Comment actions Permalink
  • I've had all of the same issues with my zoho email address. Is this something we can expect to see fixed soon?

    0
    Comment actions Permalink
  • Update: If you disable 2FA then use mail.zoho.com so it will allow you to edit the port, change the smtp address back to smtp.zoho.com once you have changed the port to 465. Leave SSL switched on. Use your email address as the user name (making sure not to use an alias) and your usual zoho password.

    After having all the same issues as Jeremy I found this to work. You do loose 2FA for now but I'm sure that's only a matter of time till a fix is developed.

     

    0
    Comment actions Permalink
  • Hi Charlie and Jeremy,

    Two factor authorization would prevent the system from being able to authorize your email address, so disabling that should help tremendously.

    0
    Comment actions Permalink
  • You don't have to turn off two factor authentication, but you have to get Zoho to generate an application specific password. 

    Follow the steps above using this password instead of your regular Zoho password and it should all work.

    0
    Comment actions Permalink

Post is closed for comments.