Delete a Lead Status

Thanks for looking into this issue for me, but I think you closed it prematurely. It is not, in fact, "Solved." When I go into System Settings and click on Lead Statuses, I don't have the option of hitting the delete button for any status, including the one in question, which I renamed "null." It's not associated with any Lead, but I can't get rid of it.

BTW, please pass this on to your management. I'm reading an interesting book called "The Endangered Customer" by Richard Shapiro. Here's what he says about "Do Not Reply" emails like the one I got from you: "... simply telling someone not to reply is tantamount to telling him or her that what he or she has to say just doesn't interest you." I have to agree.

You don't make it easy to get help, really.




  • Hey John,

    I apologize for the confusion. We strive to listen to and support our customer to the best of our ability.

    It sounds like you may have Leads within the Recycle Bin with that Lead Status applied.

    I would recommend permanently deleting all Leads within the Recycle Bin, and then trying to delete the Lead Status from System Settings.

    You can empty the Recycle Bin by navigating to Leads > Right-Hand Sidebar > "Recycle Bin".

  • Same issue here, I also tried to delete the content of recycle bin, I don't have any lead in a specific status , but still I cannot delete that status, why? 

  • Same issue here I also tried to delete and have no leads with that status

  • Hello Madison,

    Can you please clarify for me the issue you are having in regards to your Leads. I'd like to hear more on the exact issue and your steps to help better troubleshoot this for you. 

    Thanks for your time and patience. 

  • @Alejandro Another Insightly team member helped me find the issue. I forgot to check the all deleted folder. Thank you for the follow up.

  • Hello Madison,

    Perfect, glad everything worked out for you. 

    Enjoy the rest of your day and weekend. 

Post is closed for comments.