Basic Key combinations (like ctrl+a) not working for me.. how about you?

I shared the following issue with the Insightly support and they have replied that they can not reproduce the issue. I trust that they are looking into it, but I am afraid that without other people also seeing the same issue, they may not be able to address it. Have you ever experienced the following?

When editing some text fields/textareas in a project/note/tasks/etc, I can not use certain key combinations. In other text fields/textareas on the same page, those same combinations does actually work. These key combos include ctrl+a, ctrl+left arrow, ctrl+shift+left arrow. And in a place where ctrl+shift+left arrow does not work, ctrl+shift+right arrow does. Very strange.

The Insightly support asked my to provide specific situations where the issues were found. I provided the following detailed list:

Adding a Task:

  1. I clicked the Task List nav on the left side of the page
  2. Added a new task
  3. I tried the following on the specified fields:
  • Task Name: ctrl+anything works properly.
  • Due Date: ctrl+a works. The left and right arrows are taken over by the Datepicker plugin (which is appropriate/expected)
  • Add New Link: ctrl+anything works properly
  • Description: ctrl+left arrow, ctrl+shift+left arrow, ctrl+a do not work. Right arrow, copy, cut, paste, work properly.

Adding a Note (into a project)

  1. I clicked the Project List in the left hand navigation
  2. I clicked the name of a project, and then clicked the Notes tab for that project
  3. I click Add Note and tried the following:
  • Note Title: Ctrl+left and right and shift all work here. But ctrl+a does not
  • Body: ctrl+left arrow does not work here
  • Body: ctrl+shift+left arrow (select word left) does not work herectrl+a (select all) both does and does not work (see notes below)
  • Body: ctrl+right arrow DOES work here
  • Body: ctrl+shift+right arrow (select word left) DOES work here

Editing project details

  1. Click the Project List in the left hand navigation
  2. Click onto a project to see the project details
  3. Click edit and fill out the following fields:
  • Project Name: ctrl+anything works properly.
  • Description: The only thing not working is ctrl+a. right, left, shift+ all work.

Above I mentioned that when adding a note ctrl+a worked and also did not work. I know this sounds incorrect, but that is my experience. When I ran through the test the first time it did not work. I clicked around to other pages and came back to add a new note. The second time ctrl+a did actually work. I cancelled the new note, clicked around and came back to add a note. Once again, I was not able to select all. When I view my developer console I do not have any errors at this time. I also clicked around leaving the console open and did not ever see anything that would be an issue (JS errors, missing files, bad ajax calls, etc).

My specific tests above were done within both Firefox and Chrome, on a Linux (Ubuntu) OS. I also ran the same tests on a second Ubuntu installation, on my Windows 7 machine, and a friend's computer running a different Linux distribution. So that is 4 computers, 2 different OS's, and (collectively) 9 browsers, all with the same issue.

Though what I mentioned above does not sound like a big deal, it is tough to manage larger sets of notes / data within my Insightly installation. I have started to use an outside text editor to change larger sets of text, but that does not work well either. This is because when you paste in the text from your text editor, the line breaks in the text itself are removed by the Insightly textareas (which should not happen in a normal textarea). This means it I have 4 paragraphs of text and paste it into a note, the line/paragraph breaks are removed and I now have 1 large paragraph.  At that point I need to reformat (add in line breaks again), which takes too much time.

Have you ever had any issue like this? Can you run a few tests?



  • Hi Jeff. I'm moving your post to Questions and Answers so the community can comment. Thanks! 

    Comment actions Permalink
  • Thank you.

    Comment actions Permalink
  • I have the same issue on Mac OS El Capitan with Chrome and Safari as well as Windows 7, 8, and 10 using IE, Edge and Chrome. 

    Comment actions Permalink
  • @Duke - Thank you for letting us know!

    Comment actions Permalink

Please sign in to leave a comment.