Answered

Copying Email Addresses

When right clicking on an email address in a Contact and select copy email the email address is not copied correctly.  Please correct this.

2

Comments

20 comments
  • Thanks for bringing this to our attention.

    What seems to occur for you? I am able to right click and click on Copy Link Address, with the address copying completely.

    0
    Comment actions Permalink
  • If you scroll over an email address such as in a contact and right click and select copy email address and paste that email address into the address bar of an email the address is garbled.  For example, if the email address was info@insightly.com it would come out as info%40insightly.com.  In other words the @ symbol is replaced by the character %40.

    0
    Comment actions Permalink
  • This may be a browser issue. Have you tried a different browser? A workaround is to highlight the email address and copy.

    0
    Comment actions Permalink
  • Hi,

     

    I get the same problem, using Chrome

    When you right click and select 'copy email address' it replaces the @ with a %40

    0
    Comment actions Permalink
  • Hi Mel,

    Have you tried Firefox or a different browser?

    0
    Comment actions Permalink
  • I have tried Chrome, Edge and IE 11  all produce the %40 in place of the @

    0
    Comment actions Permalink
  • Hi Mel,

    Can you share a screenshot of the message?

    0
    Comment actions Permalink
  • That gives the following: test%40test.com

    0
    Comment actions Permalink
  • Hi Mel,

    Thanks for providing the example. I was able to replicate this with Chrome; however it seems to work on Firefox. I'll forward this to our team to review. For the time being I would suggest highlighting the email address in order to copy it.

    0
    Comment actions Permalink
  • Any update on this? so much easier to right click and copy instead of highlighting.

    0
    Comment actions Permalink
  • Hi Mel:

    The workaround is going to be your best option. I'm afraid we don't have the resources to pursue this.

    0
    Comment actions Permalink
  • Hi Lyla,

    After a test, a working solution could be to not completely urlencode the mailto link so that the "@" character would still be present in the href link (instead of %40).

    In my test, this solves the "copy e-mail address" problem and keeps the href link usable.

    An example url encoding code for this in PHP can be found here: http://stackoverflow.com/a/31152962

    Here is a copy of the code causing currently the problem :

    <span id="email-34439999" class="inlineEditableEmail allEditables editable editable-click editable-disabled" data-value="{newvalue:'user@gmail.com',contactlabel:'WORK'}" data-type="contactinfo" data-name="contactinfo" data-params="{subKey:34439999}" data-pk="2009879999" data-url="/contacts/EditInline" tabindex="-1">
    <a class="nopjax" target="_blank" href="mailto:user%40gmail.com?bcc=dddd%40mailbox.insight.ly&amp;" id="email-34439999">user@gmail.com</a>
    <span class="text">Travail</span>
    </span>
    0
    Comment actions Permalink
  • This problem is resurfacing for MacOS Safari Version 11.0.1 (13604.3.5).

    I did not experience the @ to %40 until switching to the New Experience.

     
    0
    Comment actions Permalink
  • It is still a problem even now. The problems just grow. 

    0
    Comment actions Permalink
  • Hello John,

    Can you provide your exact steps when encountering this issue along with a screenshot to showcase the issue? 

    0
    Comment actions Permalink
  • Alright.

    1. Open insightly contact
    2. Right click on contact email address and select "copy email address"
    3. Paste into to field of outlook 
    4. Get below result

     

    I use chrome, but same issue across browsers.

    0
    Comment actions Permalink
  • Hey Alejandro,

    If you climb up the thread you'll find screenshots : https://support.insight.ly/hc/en-us/community/posts/204677568/comments/212461648

    I also gave you the exact code which causes the issue : https://support.insight.ly/hc/en-us/community/posts/204677568/comments/115000298708

    But this is never going to be fixed. It's a 3-years old issue you don't seem to care about.

    0
    Comment actions Permalink
  • Hello Clus'Ter Jura,

    I'm sorry you're having trouble with that. It sounds like your issue could be related to your web browser.

    To check if it’s the browser, can you try accessing the page with a different browser than the one you have been using? We recommend Firefox or Chrome and make sure that you've updated your browsers to the latest available version.

    If it works in another browser, I suggest logging out of all accounts, clearing the original browser’s cache, then signing back in to see if that resolves the problem. Here are the instructions for how to clear your cache; we've included instructions for all popular browsers, so regardless of which browser you use, we've got you covered:

    Chrome
    Firefox
    Microsoft Edge

    I hope that helps. If not, let me know which operating system and browsers you've tried and I'll continue to investigate. 

    0
    Comment actions Permalink
  • Hi Alejandro,

     

    I switched to the latest Insightly interface.

    I did a complete CCleaner cache clean.

    Tried with:

    • Opera 54.0 : not working
    • Chrome 68.0 : not working
    • Firefox 61.0.1 : working

    It seems that your teamate Nora got it right, that it's a chrome-related issue (https://support.insight.ly/hc/en-us/community/posts/204677568/comments/212482868)

    All done on Windows 10 64bits edition. 

     

    Regards,

    Thomas.

    1
    Comment actions Permalink
  • Hello Clus'Ter Jura,

    Glad it's all working for you now!

    Thanks for also giving the troubleshooting steps a try.

    Enjoy your weekend!

    0
    Comment actions Permalink

Post is closed for comments.