API Key Not showing

I am trying to test Insightly as replacement for Highrise CRM.... In doing my test, I would like to test the import2 conversion tool, however it is asking for API key. I find where API key should be displayed, however the field is blank. Is this perhaps because I am on the free version?  If so, is there a way to see how our data will convert from HR?

0

Comments

8 comments
  • Official comment

    Hi David,

    You can find your API key in the User Settings page. Click on the icon in the upper right corner of the screen and you'll see a drop list of options which includes User Settings.

    Brian McConnell

    Insightly Engineering Team

    Comment actions Permalink
  • Hi David,

    Thanks for reaching out!

    You can find Insightly's full API documentation here.

    This article may help as well: Getting Started with the Insightly API.

    If you have other questions after reviewing this material, let us know :)

    0
    Comment actions Permalink
  • Hi David,

    Did you get this sorted out? The API is available to free users (there is just a limit on the number of queries you can make per day). Just go to user settings, and scroll down and you should see it there.

    Also, when you make requests to the API, you'll need to base64 encode the API key and use that as the username for basic authentication (leave the password blank). I recommend using the Postman extension for Chrome to do your testing. Its great for troubleshooting API integrations.

    0
    Comment actions Permalink
  • I am having this same problem.  I am logged into my account (not free) and the api field is blank in my user settings page.  I need that api key to accomplish an important task today.

     

     

    0
    Comment actions Permalink
  • Hi Shane,

    Our records show your API key is showing. Can you share a screenshot of what you're seeing?

    0
    Comment actions Permalink
  • Hi Shane,

    I am the engineering support lead for the API. I ran some tests, and the key shows up where it should for the instances I tested. Should should see it on the User Settings page (small print, near the bottom of the page). If you're still stuck on this, please open a support ticket, and include a screen shot, your instance ID, etc, so we can try to reproduce the issue. 


    Thanks,

     

    Brian McConnell

    Insightly Engineering Team

    0
    Comment actions Permalink
  • I'm having a similar problem.  I don't see the API key, it is blank but my account is not free.  I'm not a developer, so how and what do I need to get the API to use for integrating Insightly with other apps? 

    0
    Comment actions Permalink
  • Hi Dena,

    Did you try refreshing the setting page once you've landed on it the first time? Please let us know if that works or if you still continue to have issues with not seeing the api key.

    Best Regards,

    Patrick 

    0
    Comment actions Permalink

Please sign in to leave a comment.