CSV export error with commas in description field

Dear Insightly Team,

we have some trouble with exported CSVs. Excel separates columns with a comma. However, we also have commas in description fields. That means for an export: excel thinks with each comma in the description field a new collumn is starting.

This brings us into big trouble.

What can we do about this?

 

greetings, Aryan

1

Comments

14 comments
  • Hi Aryan:

    Some users have been successful with opening their file then doing Find & Replace fpr tthe commas in the description column. Once you do this you can re-save as a CSV file.

    Hope this works for you!

    0
    Comment actions Permalink
  • Thanks for the reply Lyla. This is not really a solution for us since excel does not know where the description field ends. Here an example:

    Last name, first name, organization, description, Tag 1, Tag 2, Tag 3

    So when I have 2 commas in the description field, excel would think after the first comma Tag 1 starts and after the second comma Tag 2 starts. Even though it is still information from the description field. 

     

    Is there some way to export the file differently?

    0
    Comment actions Permalink
  • Hi Aryan:

    There isn't an option to change the export file format from Insightly.

    Maybe one of our users will comment with some advice for you.

    0
    Comment actions Permalink
  • Hey Lyla,

    I need exports for data analysis and as backup. What you are telling me is that if there is any comma (e.g, in the description field) my whole export will be useless?!?!

    A simple example: I go on "export leads" and then import the exact file again to insightly. This will get totally messed up if there is a comma in any field. At this stage I have only exported and imported the same file that insightly gave me.

    This cannot be correct.

    Greets, Aryan

    0
    Comment actions Permalink
  •  

     

    Hi Aryan:

    There are many variables in excel that can affect formatting of your file. Due to the many versions and settings we are unable to track down what might be affecting your data specifically.

    We've done testing and the commas in a description (or background for Contacts) are not separated in the export file.

    0
    Comment actions Permalink
  • Hallo I had the same problem with the csv file: it starts a new line when "description" field is somehow long or contains a comma or a dot...

    Is there anything I can do?

    Best regards,

    Enrico

    0
    Comment actions Permalink
  • Hi Enrico,

    Is this occurring with just one record you export or all records that have a long description with?

    0
    Comment actions Permalink
  • The problem is occurring for all records and apply also to opportunities export. I tried to open the .csv file in different ways, but I always had the same problem.

    0
    Comment actions Permalink
  • Hi Enrico,

    I'm going to open a support ticket for you. Would you be able to forward your export file so we can take a look at it?

    0
    Comment actions Permalink
  • Better late than never.
    My 5 C

    In my version of excel , spanish, it will actually generate semi colons ";" and until I didn't make a change using notepad.. it was hopeless.

    0
    Comment actions Permalink
  • Hi Leslie,

    If your version of excel is looking for semi colons as the separator, you can open the CSV file with a decent text editor like Notepad++ and add the following text in the first line:

    sep=,
    

    Now open it with excel again and it should use the separator you defined in the file.

    0
    Comment actions Permalink
  • Hi all. I changed computer recently and today, nightmare! All CSV reports from Insightly had broken lines. But I solved it. There is a setting in Windows that applies all accross softwares including Excel. In Windows 10, navigate to Start > Control Panel > Region > Additional Settings > List Separator. Change the default separator by "," as it is in Insightly. Be sure to confirm by clicking "Apply". Hope this helps. 

    1
    Comment actions Permalink
  • Thank you for sharing Luc, this is great!

    0
    Comment actions Permalink

Please sign in to leave a comment.