Completed

Date Format

Hi

Did anything every get done about the date format as I am new with 3 x users and the US date format is really causing issues and we might have to change CRM my staff are complaining so much, surely it's easy fix to add a user setting for the date format ?

18

Comments

44 comments
  • We have the same issue for Australia. So the date format is determined by the Language.  What does the country setting determine?  

    0
    Comment actions Permalink
  • Thank you Alex, what do you mean that dd/mm/yyyy is overridden by the United States? My PC is also setup for the UK, not the US, see below. Is the language conflict happening somewhere else?

    0
    Comment actions Permalink
  • In this case, you would need to change the language to something besides English, as English will default to using the mm/dd/yyyy used in the United States. 

    0
    Comment actions Permalink
  • Hi Alex,

    What language should I select that I can understand, that displays the date in the UK format?

    0
    Comment actions Permalink
  • Hi Alex,

    Can you give us some clear instructions as to what settings we need to use in order to get the UK date format? Your post implies that it is possible but does not clearly explain how. Can you please clarify

    Does the function exist?

    What combinations of language and country settings do we need to use to achieve this?

    If the function does not exist how long before we are able to do this?

    Many thanks in advance for your response.

    0
    Comment actions Permalink
  • Hello Everyone,

    Our apologies for the UK there isn't a separate date format. If you like to change the date format however in the future you'll need to adjust your Language Settings. To do so go to User Settings > Language Settings in your Insightly Account. 

    0
    Comment actions Permalink
  • Thanks Alejandro. 

    But what Language Setting do we use that still displays in English and has the dd/mm/yy date format? 

    I can only see non-English languages that I, unfortunately, can't read.

    Thanks!

     



    0
    Comment actions Permalink
  • No problem Terena,

    I apologize currently there isn't an option to adjust the date format to dd/mm/yy and keep the English language. 

    0
    Comment actions Permalink
  • So the implication with the thread seems to be that if you change your lang to e.g. French, re-export, then change language back you can actually get your dates in dd/mm/yy format. A bit of a pain but c'est ok if it works.

    So I change my language to French, re-export opportunities and there is no difference to the messed up way dates are presented when the csv is opened in Excel. Am I missing something?

    I've added  a screen grab below, with annotations for anyone else scratching their head about what's going on with their dates.

    0
    Comment actions Permalink
  • Come on Insightly!

    Please listen and allow non-US date formats. We are from Australia and, like the UK, we use DD/MM/YYY and do not want to have to manually change our CSV files each time just to be compatible with ONE and ONLY piece of US-centric software when importing.

    0
    Comment actions Permalink
  • Hey guys,

    We understand the inconvenience this is causing our UK and Australia users and this has been brought to the attention of our product team. While we do not have a date for an update on this, we are working to improve all functions of Insightly as quickly as possible. 

    0
    Comment actions Permalink
  • Alex,  I am in the US and I want the date to be MM/DD/YYYY mine is defaulting to DD/MM/YYYY which is not our standard and it is causing mistakes.  I have opened two tickets and both times I am told that the MM/DD/YYYY is not an option and that because this is an internationally used program they went with what the majority of the countries use.  I was told I could post request an enhancement.  When I started doing that I came across this thread and  I see people posting they have the reverse issue, theirs is MM/DD/YYYY and they want DD/MM/YYYY.  I have my county set to the United States and language to English.  Am I missing something here?  It seems like conflicting answers regarding this.

    0
    Comment actions Permalink
  • Hey Donetta,

    It looks like a member of our are team is already investigating this for you on a support ticket and will reach out to you there.

    0
    Comment actions Permalink
  • Thanks for all the comments, everyone!

    The main thread for this topic can be found here. Please provide your comments and upvotes to the main thread. 

    We thank you for all the great suggestions! 

    0
    Comment actions Permalink

Post is closed for comments.