Exchange 2016

I don't know if this is where I should post this question......I asked our IT department to integrate outlook with Insightly and this is what they wrote (I don't understand this stuff):

We’ve reviewed the requirements for this plugin:
• It requires Office 2013 or newer – you’re currently running Office 2010, but we can definitely upgrade you to either 2013 or 2016 edition
• It requires Exchange 2013 only – we currently provide Exchange 2010 services and Exchange 2016 services, but there are no plans for an expensive 2013 implementation, since we’ve already surpassed that version

Therefore, please keep in touch with the vendor, and once they support Exchange 2016, we’ll be happy to revisit this and deploy it for your use.

Can you provide a response?

Thanks in advance.

 

0

Comments

1 comment
  • Hi Nora,

    First, I must say you have an EXCELLENT name!

    It sounds like your team is sharing that you may not have the capability to be set up with the Insightly Outlook app at this time. You can review the requirements needed here; but I would recommend following up with your IT team directly if you have any further questions on when updates or newer versions of Outlook will be available.

    0
    Comment actions Permalink

Please sign in to leave a comment.