Exchange 2013 settings

When attempting to add our on-premise Exchange 2013 server via the Add Email Accounts function under User Settings, nothing I've seen in Insightly documentation / forums actually works.

Our mail is scanned via third party (GFI) and as such, our mx record points to their servers. With these conditions, even when I set up a new Outlook profile on a machine that is not even on the LAN, I can let the autodiscover figure it all out and it works. However, the autodiscover on Insightly never works.

So far I've attempted to point Insightly to the GFI servers (as documented in our MX record) and the response is "username and password was not correct." I've tried every format for username that I can come up with (as I've seen others on this forum mention as well) and it never works.

I then tried bypassing GFI, entering the public IP address of our mail server, and opening up the firewall to Insightly (204.94.91.128/25) and it's no different.

Is there a functional documented way to make Insightly work with Exchange? 

0

Comments

5 comments
  • Hi Court:

    Some email service providers will require you to turn the SMTP option on so that the server can be autodiscovered. I also found this help article on GFI Software's site, if this is the same software you are referring to you may find it useful - How to install MailEssentials on an SMTP Relay.

    Steps on how to set your email account up are available here. Also, since you're connecting to a third party rather than to Outlook directly using the "Other" option would be the recommended set up.

    0
    Comment actions Permalink
  • This is an on-premise Exchange 2013 server. SMTP is turned on. I've been using the Other option from the start. If I bypass GFI and point Insightly directly to our mail server via DNS name or IP address, I get prompted for Email Address, Username, and Password. When I enter this info, the response is "Username or Password you supplied was not correct." Since I can successfully login to our mail server remotely to send and receive mail, I know for certain that the username and password is correct. All of our staff here have smartphones (both iphones and android), and all of the Exchange accounts on these phones were set up via Autodiscover. Furthermore, the Exchange logs don't indicate that there is any connection attempt from Insightly's network 204.94.91.128/25 on port 25, ever. I'm guessing that the message "Username and Password was not correct" is inaccurate and that for some reason, there's a communication error. But....

    Just for fun, I went into the Exchange settings, and added our *.asmx server address to the Server field. However, in the Email field, I just have my Windows account name (not my email address). After entering my password and clicking on Save Exchange Settings, the message returned is "Exchange settings saved" even though there is no legitimate email address in that field. If I try entering my email address there, the process fails with the error "Authentication failed ... 401 Unauthorized." I've gone as far as syncing my Calendar to Insightly, and it works with these settings.

    I'm not sure how useful Insightly will be if we can't get the email to function. Is there a way to open a ticket on this or otherwise escalate this?

    Thanks

    0
    Comment actions Permalink
  • Hi Court, 

    We are going to reach out to your directly regarding this issue. An email will be sent to you soon, so please keep an eye out! 

    0
    Comment actions Permalink
  • Hello Leslie, or who ever may be watching this forum.

    We have  the very same issues, we just opened an account 3 months ago with Insightly.com to use the CRM database.

    currently we have had no luck with Insightly's support team in answering the very same questions posted above. 

    The question that needs to be answered is as follows " Can or has Insightly ever been successfully deployed with an on premise exchange server  2013 or 2016? " I have emailed support many times and it takes support to even try and troubleshoot SMTP with SSL  when they do test this all we get from support is that user authentication failed. 

    I feel that the lack of response by Insightly's team on the question above as they avoid the question CAN THIS OR HAS THIS EVER WORKED WITH AN On Premise Exchange server successfully?  or is this a hosted solution only ? is totally avoided and never answered. it's a simple yes or no question.

     

    our errors are as follows ... with a trial of our server onsite and at our colo onsite has the following barracuda appliance where mail is received from smtp using TLS / SSL auth then it's passed to a connector going to exchange 2013. we get the same error as below from the colo the colo has no firewall and no barracuda appliance... see error below for the colo response from Insightly testing.

     

    I received the following "Bad Credentials" error. So it seems we can connect to the server, but can't verify. We currently do not support NLTM authentication at this time.  [15:29:16.41] [INFO] Assembly version: 10.0.45.502. [15:29:16.41] [INFO] Will test sending mail message. [15:29:16.41] [INFO] Will resolve host "mail.xxxxxxxx.com". [15:29:16.41] [INFO] Host "mail.xxxxxxxx.com" resolved to IP address(es) 66.181.xxxx.xxxx. [15:29:16.41] [INFO] Will connect to host "mail.xxxxxxxx.com" on port 25. [15:29:16.45] [INFO] Socket connected to IP address 66.181.xxx.xxx on port 25. [15:29:16.49] [RECV] 220 ***************************************************************************************************\r\n [15:29:16.49] [INFO] Connected to mail service at host "mail.xxxxx.com" on port 25 and ready. [15:29:16.49] [INFO] Will send Hello command (HELO or EHLO). [15:29:16.49] [SEND] EHLO [10.100.1.115]\r\n [15:29:16.53] [RECV] 250-VM-SGCNEXCHANGE.xxxxxxx.com Hello [4.15.73.186]\r\n250-SIZE 37748736\r\n250-PIPELINING\r\n250-DSN\r\n250-ENHANCEDSTATUSCODES\r\n250-XXXXXXXA\r\n250-XXXXXXXXXXXXXB\r\n250-AUTH NTLM\r\n250-XXXXXXXXXXXXXXXXXC\r\n250-8BITMIME\r\n250-BINARYMIME\r\n250-XXXXXXXD\r\n250 XXXXE\r\n [15:29:16.53] [INFO] SMTP Hello completed. [15:29:16.53] [INFO] Will login as "avalades". [15:29:16.53] [INFO] Will try SASL NTLM authentication method. [15:29:16.53] [SEND] AUTH NTLM\r\n [15:29:16.56] [RECV] 334 NTLM supported\r\n [15:29:16.56] [SEND] TlRMTVNTUAABAAAAB4IIogAAAAAAAAAAAAAAAAAAAAAGAbEdAAAADw==\r\n [15:29:16.60] [RECV] 334 TlRMTVNTUAACAAAAFAAUADgAAAAFgomizonsBORoCPQAAAAAAAAAAMoAygBMAAAABgOAJQAAAA9TAEMAQQBSAFIASQBUAFQAQwBOAAIAFABTAEMAQQBSAFIASQBUAFQAQwBOAAEAHgBWAE0ALQBTAEcAQwBOAEUAWABDAEgAQQBOAEcARQAEABwAcwBjAGEAcgByAGkAdAB0AGMAbgAuAGMAbwBtAAMAPABWAE0ALQBTAEcAQwBOAEUAWABDAEgAQQBOAEcARQAuAHMAYwBhAHIAcgBpAHQAdABjAG4ALgBjAG8AbQAFABwAcwBjAGEAcgByAGkAdAB0AGMAbgAuAGMAbwBtAAcACABI3ThL2J7TAQAAAAA=\r\n [15:29:16.60] [SEND] TlRMTVNTUAADAAAAGAAYAHYAAABSAVIBjgAAAAAAAABYAAAAEAAQAFgAAAAOAA4AaAAAAAAAAADgAQAABYKIogYBsR0AAAAPKLNrgrCXq9k/zh2zZH6RlGEAdgBhAGwAYQBkAGUAcwBBAE4AVABIAE8ATgBZAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAAMTJYhOsEUdV0kpSVXO39dYBAQAAAAAAAEjdOEvYntMBZQN+nF1nDigAAAAAAgAUAFMAQwBBAFIAUgBJAFQAVABDAE4AAQAeAFYATQAtAFMARwBDAE4ARQBYAEMASABBAE4ARwBFAAQAHABzAGMAYQByAHIAaQB0AHQAYwBuAC4AYwBvAG0AAwA8AFYATQAtAFMARwBDAE4ARQBYAEMASABBAE4ARwBFAC4AcwBjAGEAcgByAGkAdAB0AGMAbgAuAGMAbwBtAAUAHABzAGMAYQByAHIAaQB0AHQAYwBuAC4AYwBvAG0ABwAIAEjdOEvYntMBBgAEAAIAAAAIADAAMAAAAAAAAAABAAAAACAAAE0ERNrPFlyNXF0lyBxsLfYpv74IV/u1eFDnOJwl7mdRCgAQAAAAAAAAAAAAAAAAAAAAAAAJAAAAAAAAAAAAAAAAAAAA\r\n [15:29:21.69] [RECV] 535 5.7.3 Authentication unsuccessful\r\n [15:29:21.69] [INFO] Will disconnect from host "mail.xxxxxx.com". [15:29:21.69] [INFO] Disconnected from host "mail.xxxxxxxx.com". [15:29:21.69] [INFO] Error: The server has rejected authentication data sent by the client. The server responded: 535 5.7.3 Authentication unsuccessful. Please let me know if you need more information. 

    Regards, Erin

    Erin T. Customer Care support@insight.ly www.Insightly.com

    it has been 1 month now from my last question to support and still no answers to the query. how do you retain your customer base if this is the support we get even though we are paying extra for support on top of the 15k for this program for the first year?

    Any help would be greatly appreciated thank you , 

    Charlie.

    0
    Comment actions Permalink
  • Hello Charlie,

    Thanks for your post and feedback!

    I see that Erin is working with you on this through a ticket that was created. The ticket number is 177621 please provide your questions there to help with better troubleshooting and communication.

    This will help us better support you!

    0
    Comment actions Permalink

Post is closed for comments.