Answered

Custom Field - Suddenly I cannot Edit

Hello,

When I go to > System settings > Objects and Fields > All the Objects have a checkbox near the column "Deployed" and there is no edit option (and no 3 dots to the right).

My use is the owner and I already crated quite a few custom fields, which i was able to edit or add to - with no difficulty - before. Now suddenly i cannot.

Thanks for your help!

0

Comments

11 comments
  • Hello Metcomm,

    Thanks for your patience with this as I'm also happy to hear it is resolved!

    Enjoy the rest of your day and week. 

    1
    Comment actions Permalink
  • Hello Metcomm,

    All Objects populated in Insightly by default are unable to be edited. These objects are classified as "Standard Objects" which help you categorize the different types of records you have. You'll notice these Standard Objects do not have the "Custom" column checked off. Because of this, you are unable to click on the 3 dots to edit them. 

     

    When you try adding a custom field to an Object can you provide your exact steps? This will help me further troubleshoot. 

    Hope that helps explain the 3 dot issue and looking forward to your reply! 

    0
    Comment actions Permalink
  • Thanks, Alejandro.

    That's where I'm going to edit my custom fields: System settings > Objects and Fields . I wanted to add another option to Opportunity "Current State" drop menu - but everything seems to be grayed out. 

    Thank you

     

    0
    Comment actions Permalink
  • Hello Metcomm,

    To add another custom field for Opportunities you'll need to follow these steps:

    1. Click the profile icon and go to the System Settings page.
    2. Select Objects and Fields.
    3. Select the object you’ll be creating fields for (Opportunity)
    4. Select Object Fields from the Object Management menu.
    5. Click New Field.
    6. Choose a field type and click Next.
    7. Click Save Custom Field.
    8. Add the new field to a page layout.

    Here's an article that helps explain more in details & with screenshots: How to create a custom field 

    Hope that helps. 

    0
    Comment actions Permalink
  • HI Alejandro.

    But I don't want to add a new field!

    All I need is to be able to do something that was very easy before: in "opportunities" there is already a drop down menu for the opportunity State. When we choose a status for the opportunity, we choose the reason from a drop down menu with reasons that we created. For instance: "Lost" > Reason = "They chose a different vendor." and we also designated a color for the reason. Now you refer me to opening a new field. This is confusing, to say the least. Thanks.

    0
    Comment actions Permalink
  • Hello Metcomm,

    I suggest going to your System Settings > Objects & Fields > Click on Opportunity > Object Fields then you should see the custom field that you created and proceed to edit it. 

    If you don't see the three dots to edit this field please provide a screenshot clarifying this. 

    Thanks for your help and patience. 

    0
    Comment actions Permalink
  • Thanks, Alejandro. I am attaching a prt screen. I cannot edit the "Current State" field. Thanks

    0
    Comment actions Permalink
  • Hello Metcomm,

    Thanks for that screenshot!

    The field "Current State" is not a custom field as you can see the custom field column does not have a check mark. A check mark helps identify which fields are custom fields. If you like to add more fields to the current state I suggest creating a custom field for this. This will allow you to add more fields and customize your own personal custom "current state" field. 

    0
    Comment actions Permalink
  • Dear Alejandro,

    I am afraid this is a "loop"; if you go back to my original post, this is exactly what i was mentioning - that it is marked as "deployed" and not "custom". However, I DO HAVE customized fields to which I need to add more options (to the drop down menu). This is frustrating! why isn't it "straightforward" as before? We need a solution. Thanks

     

    0
    Comment actions Permalink
  • Hello Metcomm,

    I think I found the confusing here. It seems you are looking for the "Opportunity States" setting. If you go to your System Settings > Opportunity States > you'll be able to add more Opportunity States to this default field. 

    The confusion came from stating custom fields which are different from this setting. 

    Hope that helps. 

    0
    Comment actions Permalink
  • Great, Alejandro! 

    That's exactly it! at last I see what I searched for all the time and couldn't find like before.

    (Wasn't these settings before under "custom fields"?)

    I appreciate your help and your patience! 

    Thanks much!

    0
    Comment actions Permalink

Post is closed for comments.