Projects Pipelines and Stages Cannot Be Updated in Either 3.0 or 3.1

Hey all,

3.1 does not work at all with the PipelineStages endpoint to update the stage, activity set, activities, etc. 

I've tried with Zapier Webhooks and Postman. It just passes the data and does nothing. Says it works, but nothing changes.

So I tried 3.0 which also does not work old school with a simple JSON string such as

"PROJECT_ID": 11231069,
"PIPELINE_ID": 883552,
"STAGE_ID": 3596163

I love the 3.1 concept:


But nothing I try will get the stage to update. I've read others also stating the same. I need to be able to use these features. Your help is appreciated.

Eric Greenspan
Chief Clever Officer

Disclaimer: While I'm not a direct employee of Insightly, I am a member of their Hero program and recognized as an experienced power user. I'm also a big fan. I use Insightly for all my clients and my internal business management. I extend it to do more through the API. Again, I'm a big fan. I'm also a Zapier Certified Expert II, PandaDoc Pro and a Piesync Expert.



1 comment
  • Official comment

    Hey Eric - this isn't a bug or issue. 

    For updating the pipeline, you need to use this endpoint: 
    And it requires sending this payload, with all the correct ids:
      "PIPELINE_ID": 620994,
        "STAGE_ID": 2384947,
          "ACTIVITYSET_ID": 1087149,
          "START_DATE": "2020-06-10T22:08:35.713Z",
          "END_DATE": "2020-06-10T22:08:35.713Z",
              "ACTIVITY_ID": 2385969,
              "RESPONSIBLE_USER_ID": 1792211
              "ACTIVITY_ID": 2385971,
              "RESPONSIBLE_USER_ID": 1792211
    So you have to know the pipeline id, the stage id, the activity set id, and each activity id that is in the activity set
    For updating the stage, you need this endpoint:{project_id}/PipelineStage  with all the same payload requirements
    Comment actions Permalink

Please sign in to leave a comment.